[Logo] JForum - Powering Communities
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Members] Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register /  [Login] Login 


JForum 2.5.0 released, download it from here.
Error in the Source Code of Jforum 2.3.5  RSS feed
Forum Index » Developer Forum
Author Message
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi jForum Support Team,

I have successfully built up the jForum 2.3.5 source code in NetBeans IDE v8.0.2 in my personal laptop. The project can be run and I can access the jForum pages to post my topics without any problem. However, there is still a source existing in the "WebRequestContext.java" file in the "net.jforum.context.web" package.

The error hint is "getParameterNames() in net.jforum.context.web.WebRequestContext cannot implement getParameterNames() in javax.servlet.ServletRequest return type java.util.Enumerationjava.lang.Object is not compatible with java.util.Enumerationjava.lang.String".

When I log in with an admin account and do some changes in the admin control panel (for example modify the "permission" for groups) then click "Save". The same error occurs.

I have attached the screenshot, please have a look and help me out of this as soon as possible.

P.S.: I'm not familiar with the coding stuff. So if you could help me, please describe the solution in a plain way for my better understanding. Thanks in advance!

Kind Regards

Drake
YVN Technology
[Thumb - jforum code error.png]
 Filename jforum code error.png [Disk] Download
 Description No description given
 Filesize 42 Kbytes
 Downloaded:  16975 time(s)

[Thumb - jForum error.png]
 Filename jForum error.png [Disk] Download
 Description No description given
 Filesize 71 Kbytes
 Downloaded:  17533 time(s)

andowson


Joined: 2011/6/30
Messages: 198
Offline
Please remove that method getParameterNames() from WebRequestContext.java, and build it again.
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi, I removed the method getParameterNames() and rebuilt the program, but failed. New errors occured in the WebRequestConext class, and I can't access the jForum pages when I run it. I have attached the error screenshots, please have a looksmilie

P.S.: Have you ever met such a problem when you run the source code of Jforum 2.3.5? If not, could you provide your Jforum 2.3.5 code for me please?

Kind Regards

Drake
[Thumb - 2.png]
 Filename 2.png [Disk] Download
 Description No description given
 Filesize 141 Kbytes
 Downloaded:  17646 time(s)

[Thumb - 1.png]
 Filename 1.png [Disk] Download
 Description No description given
 Filesize 65 Kbytes
 Downloaded:  17302 time(s)

andowson


Joined: 2011/6/30
Messages: 198
Offline
Sorry, are you using JDK8? Try switching to build with JDK7 and add back that methods.
BTW, version 2.4.x is more secure than any previous version, so you can also download the latest code from SVN trunk.
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Yes, I'm using JDK8. Does Jforum 2.4.0 support JDK8?
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi, I downloaded jForum 2.4.0 from SVN and tried to build it in my NetBeans IDE v8.0. It seems more errors exist in Jforum 2.4.0 than Jforum 2.3.5. I have been stuck on this problem for 1 month. Could you please send me the source code of either jForum 2.3.5 or jForum 2.4.0 which can be successfully run in NetBeans please? My email address is drake@yvntech.com. Thanks in advcance!!
andowson


Joined: 2011/6/30
Messages: 198
Offline
Hi, sorry that JForum 2.4.0 can't be compiled with JDK8 right now.
JDK8 introduces many new features and deprecates some methods, this will cause a lot of conversion work.
And we keep the minimum system requirement of Java 6.
I'd suggest you switch back to JDK 7 for compile JForum 2.3.x or 2.4.x.
Your days will be much happier.

BTW, I use eclipse to build JForum, so I don't have the source code for NetBeans. And all source code is published on googlecode svn.
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi, does jforum 2 support glassfish?
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi, I have switched the JDK 1.8 back to JDK 1.7.0_75, but the problem still exists. Could you please try to build jforum using glassfish server in the Netbeans IDE v8.0 to what happens? Please help me out. Thx in advance.
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi, I downloaded the source code from your SVG via http://jforum2.googlecode.com/svn/trunk/. But I found there is no "install.jsp" and "index.jsp" files. How can I get these two files for jForum 2.4.0?
andowson


Joined: 2011/6/30
Messages: 198
Offline
JForum 2.3.x and later uses maven as build tool, you can follow the maven directory structure and find the two files under /src/main/webapp
http://jforum2.googlecode.com/svn/trunk/src/main/webapp/

This URL maybe help for usgin Maven in NetBeans:
https://netbeans.org/kb/docs/javaee/maven-entapp.html
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi, I thank you for your help. I have set up the jforum 2.4.0 source code in Netbeans IDE. But when I try to build it. The same error occurs as it does in jforum2.3.5:

"getParameterNames() in WebRequestContext cannot implement getParameterNames() in ServletRequest
public Enumeration<Object> getParameterNames() {
return type Enumeration<Object> is not compatible with Enumeration<String>"

I can run the project and access the main page of jforum and use normal account to post or reply topics. However, there is still some problem when I use Admin account (The same problem as in jforum 2.3.5, please see the screenshot in my first post).

The weard thing is, if I use the war file. Everything is fine. Is there no one else having the problem as I do? Could you help me out of this please?
andowson


Joined: 2011/6/30
Messages: 198
Offline
All right, finally, I did download and install NetBeans IDE and build JForum with NetBeans IDE.
I checkout the latest source code from svn trunk, and without modifing any code, I can build JForum successfully.
So I suggest you clean up your workspace and download from svn again.
 Filename Build JForum with NetBeans IDE.docx [Disk] Download
 Description Build JForum with NetBeans IDE
 Filesize 1099 Kbytes
 Downloaded:  17691 time(s)

drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi mate, it works!!!!!! It seems it's the way I retrieved the code through your SVN was incorrect that cause that error. Thx heaps!!

Now I'm going to do some testing of the jforum. May I ask is there any good ways to test jforum's capacity when in a large volumn of posts scenario?

Kind Regards

drake
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi mate, how could I integrate the jforum into my existing project? For instance, I have a website project which is using the URL address www.hello.com.au (just a example). How could I access jforum through URL: www.hello.com.au/jforum? Because I'm building all the projects in Netbeans, do you have related solutions for me? Thanks in advance.
 
Forum Index » Developer Forum
Go to:   
Mobile view
Powered by JForum 2.5.0 © 2018 JForum Team • Maintained by Andowson Chang and Ulf Dittmer