[Logo] JForum - Powering Communities
  [Search] 搜尋   [Recent Topics] 最新主題   [Hottest Topics] 熱門主題   [Top Downloads] 熱門下載   [Members] 會員列表   [Groups] 回首頁 
[Moderation Log] 管理日誌   [Register] 會員註冊 /  [Login] 登入 


JForum 2.4.1 released, download it from here.
Arabic in Jforum  RSS feed
討論區首頁 » User Forum
發表人 內容
sshehab


註冊時間: 2017/04/24 17:34:56
文章: 2
離線
Hi ,
i'm trying to change the Jforum to Arabic , so i added ar_AR.properties file to config-->languages , and added it to locale.properties file , also added to the Glassfish JVM options
-Dfile.encoding=UTF8
but i'm getting the Arabic as trash as in the below screenshots , any solutions for this ?

[Thumb - Capture2.JPG]
 檔案名稱 Capture2.JPG [Disk] 下載
 描述 沒有檔案註解存在
 檔案大小 18 Kbytes
 下載次數:  1137 次

[Thumb - Capture3.JPG]
 檔案名稱 Capture3.JPG [Disk] 下載
 描述 沒有檔案註解存在
 檔案大小 15 Kbytes
 下載次數:  1213 次


Thanks
Sherif
udittmer


註冊時間: 2013/02/21 03:10:28
文章: 148
It's hard to tell what's going on without having access to the properties file; if you email it to me I can take a look.

Ping & DNS - my free Android app for TCP/IP network diagnostics
[WWW]
sshehab


註冊時間: 2017/04/24 17:34:56
文章: 2
離線
Hi sent in Private message

Thanks
Sherif
udittmer


註冊時間: 2013/02/21 03:10:28
文章: 148
I got it, but I'm having problems getting JForum to use it. Even after setting Arabic as the board default language it isn't used by JForum, and doesn't show up in my profile settings. Not sure what's going on.

In general I would say it's better to encode the language files using the \uWXYZ notation you see in Russian file, amongst others. While some files use accented characters (Portuguese, for example), those tend to cause problems.

Ping & DNS - my free Android app for TCP/IP network diagnostics
[WWW]
 
討論區首頁 » User Forum
前往:   
Powered by JForum 2.4.1 © 2015 JForum Team • Maintained by Andowson.com