[Logo] JForum - Powering Communities
  [Search] 搜尋   [Recent Topics] 最新主題   [Hottest Topics] 熱門主題   [Top Downloads] 熱門下載   [Members] 會員列表   [Groups] 回首頁 
[Moderation Log] 管理日誌   [Register] 會員註冊 /  [Login] 登入 


JForum 2.4.1 released, download it from here.
OpenJDK ?  RSS feed
討論區首頁 » User Forum
發表人 內容
Spencer


註冊時間: 2013/09/12 05:16:18
文章: 17
離線
I am working my way through getting jforum 2.3.4 working on Amazon AWS.

However, it seems jforum uses com.sun.image.codec.jpeg.* which is only in the sun/oracle JDK and not in OpenJDK.

This breaks captcha and smilies (maybe other things).

I have tried to get the sun jdk installed and used but all attempts so far have broken other functionality with more severe consequences.

I have seen some discussions where javax.imageio might be used instead the proprietary sun versions. Some examples:
http://board.jdownloader.org/showthread.php?t=32978
http://mail.openjdk.java.net/pipermail/2d-dev/2011-July/002114.html

Any thoughts on having jforum use the non-proprietary JDK?

Thanks,
Spencer
udittmer


註冊時間: 2013/02/21 03:10:28
文章: 139
The problem is, JForum does not use that package, one of the dependent libraries does (jcaptcha in this case). If it was JForum, it might not be hard to replace with ImageIO (and would be a good thing to do), but as it is one would have to patch that library. A quick look at that source code finds it used in 9 files - I'll take a look at how hard it might be to patch that, but no promises.

What do you mean about the smilies - how are they affected? Those are just static images that are shipped with JForum, and should work on any platform.

Ping & DNS - my free Android app for TCP/IP network diagnostics
[WWW]
udittmer


註冊時間: 2013/02/21 03:10:28
文章: 139
This is a JCaptcha 1.0 jar file where I have replaced the com.sun.image.codec.jpeg stuff with javax.imageio.ImageIO. Replace the jar you currently have with this one and see what happens. Please understand that I have done no testing with this, it's just a build with the altered sources.
 檔案名稱 jcaptcha-1.0.jar [Disk] 下載
 描述 JCaptchs 1.0 using ImageIO
 檔案大小 190 Kbytes
 下載次數:  2192 次


Ping & DNS - my free Android app for TCP/IP network diagnostics
[WWW]
Spencer


註冊時間: 2013/09/12 05:16:18
文章: 17
離線
That has fixed the captcha. Thank you.

The smilies were broken when I tried to solve another problem. Jforum was intercepting my <welcome-file-list> that had index.htm. I renamed the index.jsp to forum.jsp which causes the smiles to to be looked for in http://www.mapbake.com/forum.jsp/images/smilies/... instead of http://www.mapbake.com/images/smilies/...

In SystemGlobals.properties I set:

forum.link = http://www.mapbake.com/forum.jsp
homepage.link = http://www.mapbake.com/

Do you know if I can correct this without causing my main page to be intercepted by jforum?

Thanks again for your help.

Spencer
udittmer


註冊時間: 2013/02/21 03:10:28
文章: 139
I don't think I understand the problem - JForum's servlets and filter are mapped to "*.page" by default. That it would intercept an *.htm file sounds like you may have changed some things from their default...? What's more, JForum doesn't use JSP, so you shouldn't map any JSP pages.

Ping & DNS - my free Android app for TCP/IP network diagnostics
[WWW]
Spencer


註冊時間: 2013/09/12 05:16:18
文章: 17
離線
I saw that jforum servlets are mapped to *.page. I may have mis-stated what was happening. When I went to the domain with no page specified it was going to jforum and not the index.htm which I specified in the <welcome-file-list> of web.xml.

There are 3 jsp files provided with jforum (index.jsp, install.jsp, and ping_session.jsp) in web. I changed index.jsp to forum.jsp and it now goes to my index.htm instead of jforum.

I posted about this on another thread (<welcome-file-list> ignored).

I think setting SystemGlobals.properties as:

forum.link = http://www.mapbake.com/
homepage.link = http://www.mapbake.com/

may fix it. It worked locally...

I will do some more testing before deploying live later today.

Thanks for your help.

Spencer
Spencer


註冊時間: 2013/09/12 05:16:18
文章: 17
離線
It was the incorrect setting of forum link.

It is working now.

Thank you again.

Spencer
 
討論區首頁 » User Forum
前往:   
Powered by JForum 2.4.1 © 2015 JForum Team • Maintained by Andowson.com