[Logo] JForum - Powering Communities
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Members] Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register /  [Login] Login 


JForum 2.5.0 released, download it from here.
problem with maven and v2.3.1  RSS feed
Forum Index » Developer Forum
Author Message
rvanderwerf


Joined: 2011/8/13
Messages: 12
Offline
Hi, I am trying to build 2.3.1, but I keep running into this error:

generics are not supported in -source 1.3
(use -source 5 or higher to enable generics)
public List<ModerationLog> selectAll(final int startFrom, final int count)

I get similar error for all files that use generics.

I am running linux, with Sun JDK 1.60.24, maven 2.0.6

I miss the easy Ant build smilie
rvanderwerf


Joined: 2011/8/13
Messages: 12
Offline
nervermind, I just checked the requirements, and it said Maven 3. I installed maven 3, and now I can compile the project.
 
Forum Index » Developer Forum
Go to:   
Mobile view
Powered by JForum 2.5.0 © 2018 JForum Team • Maintained by Andowson Chang and Ulf Dittmer