[Logo] JForum - Powering Communities
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Groups] Back to home page 
[Register] Register /  [Login] Login 


New: JForum 2.6.0 has been released with many improvements, download it from here
How to Setup JForum Development Environment RSS feed
Forum Index » Developer Forum
Author Message
Raskolnikov


Joined: 2013/5/7
Messages: 4
Offline
Yes, i did that :/ i used the mvn command and then tried copying the driver into the proper directory but now in both cases i'm getting the following error:

[INFO] Building JForum 2.3.5-snapshot
[INFO] ------------------------------------------------------------------------
Downloading: https://repository.jboss.org/nexus/content/groups/public/com/oracle/ojdbc14/10.2.0.4.0/ojdbc14-10.2.0.4.0.pom
Downloading: http://maven.jahia.org/maven2/com/oracle/ojdbc14/10.2.0.4.0/ojdbc14-10.2.0.4.0.pom
Downloading: http://repo.maven.apache.org/maven2/com/oracle/ojdbc14/10.2.0.4.0/ojdbc14-10.2.0.4.0.pom
Downloaded: http://repo.maven.apache.org/maven2/com/oracle/ojdbc14/10.2.0.4.0/ojdbc14-10.2.0.4.0.pom (903 B at 2.1 KB/sec)
Downloading: https://repository.jboss.org/nexus/content/groups/public/com/oracle/ojdbc14/10.2.0.4.0/ojdbc14-10.2.0.4.0.jar
Downloading: http://maven.jahia.org/maven2/com/oracle/ojdbc14/10.2.0.4.0/ojdbc14-10.2.0.4.0.jar
Downloading: http://repo.maven.apache.org/maven2/com/oracle/ojdbc14/10.2.0.4.0/ojdbc14-10.2.0.4.0.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 11.260s
[INFO] Finished at: Thu May 09 03:03:38 UYT 2013
[INFO] Final Memory: 8M/123M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project jforum: Could not resolve dependencies for project net.jforum:jforum:war:2.3.5-snapshot: Could not find artifact com.oracle:ojdbc14:jar:10.2.0.4.0 in jboss (https://repository.jboss.org/nexus/content/groups/public/) -> [Help 1]


Thanks for your patience!
andowson


Joined: 2011/6/30
Messages: 213
Offline
Try to locate your local m2 repository directory for ojdbc14.
For example, mine is under the C:\Users\Andowson\.m2\repository\com\oracle\ojdbc14\10.2.0.4.0 path.
And delete all the files except the ojdbc14-10.2.0.4.0.jar.
Run your maven build command and test if this works.
Raskolnikov


Joined: 2013/5/7
Messages: 4
Offline
Negative, i get the same error as before smilie
andowson


Joined: 2011/6/30
Messages: 213
Offline
Hi Raskolnikov,
In your case, just remove the following fragment from pom.xml:
                <dependency>
                        <groupId>com.oracle</groupId>
                        <artifactId>ojdbc14</artifactId>
                        <version>10.2.0.4.0</version>
                        <scope>compile</scope>
                </dependency>

And copy the ojdbc14.jar file into src\main\webapp\WEB-INF\lib directory yourself.
Raskolnikov


Joined: 2013/5/7
Messages: 4
Offline
It worked! Thank you andowson! smilie

andowson


Joined: 2011/6/30
Messages: 213
Offline
Hi Raskolnikov,
Would you please add back the deleted part to the pom.xml and try the following command again:

mvn install:install-file -Dfile=ojdbc14.jar -DgroupId=com.oracle -DartifactId=ojdbc14 -Dversion=10.2.0.4.0 -Dpackaging=jar -DgeneratePom=true


The last parameter for generating a POM will save you from pom.xml warnings

And check if this works now?

Reference:
http://stackoverflow.com/questions/1074869/find-oracle-jdbc-driver-in-maven-repository
drake_yvntech


Joined: 2015/2/2
Messages: 12
Offline
Hi, can I build jforum with glassfish server in Netbeans v8.0??
HootinHoller


Joined: 2017/3/25
Messages: 1
Offline
Having trouble doing initial build from 2.4.1 source (build 501)

It appears that the captcha dependency has been hosed.

The error:
 Failed to execute goal on project jforum: Could not resolve dependencies for project net.jforum:jforum:war:2.4.1: Failed to collect dependencies at com.octo.captcha:jcaptcha:jar:1.0 -> com.jhlabs:imaging:jar:01012005: Failed to read artifact descriptor for com.jhlabs:imaging:jar:01012005: Could not transfer artifact com.jhlabs:imaging:pom:01012005 from/to 3rd-party (http://forge.octo.com/archiva/repository/3rd-party): forge.octo.com: Unknown host forge.octo.com 


Has anyone built this from a bare local repository lately?
Udusimus


Joined: 2017/8/31
Messages: 3
Offline
HootinHoller wrote:Having trouble doing initial build from 2.4.1 source (build 501)

It appears that the captcha dependency has been hosed.

The error:
 Failed to execute goal on project jforum: Could not resolve dependencies for project net.jforum:jforum:war:2.4.1: Failed to collect dependencies at com.octo.captcha:jcaptcha:jar:1.0 -> com.jhlabs:imaging:jar:01012005: Failed to read artifact descriptor for com.jhlabs:imaging:jar:01012005: Could not transfer artifact com.jhlabs:imaging:pom:01012005 from/to 3rd-party (http://forge.octo.com/archiva/repository/3rd-party): forge.octo.com: Unknown host forge.octo.com 


Has anyone built this from a bare local repository lately?


experiencing exact the same problem. Mentioned this in a separate thread in this Forum
 
Forum Index » Developer Forum
Go to:   
Mobile view
Powered by JForum 2.6.0 © 2019 JForum Team • Maintained by Andowson Chang and Ulf Dittmer
Website Security Test