[Logo] JForum - Powering Communities
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Groups] Back to home page 
[Register] Register /  [Login] Login 


The final version of JForum 2.7.0 has been released with lots of improvements. Read all about it here

SQL Exception RSS feed
Forum Index » User Forum
Author Message
Jux


Joined: 2012/4/13
Messages: 4
Offline
Hi,

I just installed version 2.3.3 running with Tomcat 7.0.26 and MySQL 5.5.22. Installation went fine, but when I'm trying to create new Category (after installation) I'm getting:
java.sql.SQLException: SQL String can not be NULL.

Also creating new post to this 'Test Forum' gives the same error. Editing of 'Test Forum' (for example changing the name) works ok.

Any ideas? Too new MySQL version?

Cheers,

Jux
Jux


Joined: 2012/4/13
Messages: 4
Offline
Hi,

Seems that something went wrong in the installation, after couple of more tries now it seems to work.

(update: actually now creating the topics etc works, but when I try to register new user I'm getting java.lang.StringIndexOutOfBoundsException: String index out of range: 20).

Jux


Joined: 2012/4/13
Messages: 4
Offline
Hi,

I'm stuck with this problem now. When I try to create new registration - fill in all the details (name, email, pw, ...) and click 'Submit':
An error has occurred.
For detailed error information, please see the HTML source code, and contact the forum Administrator.
java.lang.StringIndexOutOfBoundsException: String index out of range: 20

and in the jforum.log shows:

2012-04-14 14:55:19,986 ERROR [ExceptionWriter] - net.jforum.exceptions.ForumException: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at net.jforum.Command.process(Command.java:114)
at net.jforum.JForum.processCommand(JForum.java:246)
at net.jforum.JForum.service(JForum.java:228)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:169)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:168)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98)
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:927)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:987)
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:579)
at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:307)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:680)
Caused by: java.lang.reflect.InvocationTargetException
... 27 more
Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: 20
at java.lang.String.charAt(String.java:686)
at sun.net.www.ParseUtil.isEscaped(ParseUtil.java:458)
at sun.net.www.ParseUtil.quote(ParseUtil.java:424)
at sun.net.www.ParseUtil.appendSchemeSpecificPart(ParseUtil.java:354)
at sun.net.www.ParseUtil.toString(ParseUtil.java:311)
at sun.net.www.ParseUtil.createURI(ParseUtil.java:289)
at sun.net.www.ParseUtil.toURI(ParseUtil.java:266)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:905)
at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:836)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1172)
at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(XMLEntityManager.java:677)
at com.sun.org.apache.xerces.internal.impl.XMLVersionDetector.determineDocVersion(XMLVersionDetector.java:186)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:772)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:518)
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:986)
at net.jforum.security.StopForumSpam.getXmlRootElement(StopForumSpam.java:82)
at net.jforum.security.StopForumSpam.getResult(StopForumSpam.java:74)
at net.jforum.security.StopForumSpam.checkIp(StopForumSpam.java:65)
at net.jforum.view.forum.UserAction.insertSave(UserAction.java:301)
... 27 more

Any advice?
andowson


Joined: 2011/6/30
Messages: 223
Offline
It seems to be the problem of using StopForumSpam-check API introduced since JForum 2.3.2.
Does your forum server have Internet connection?
Jux


Joined: 2012/4/13
Messages: 4
Offline
Hi,

Yep, it has the internet connection - at least it's suggesting that there is new version available if I use 2.3.2 version... And with 2.3.1 this problem disappeared.

So I think you are heading to the right direction...
 
Forum Index » User Forum
Go to:   
Mobile view
Powered by JForum 2.7.0 © 2020 JForum Team • Maintained by Andowson Chang and Ulf Dittmer