[Logo] JForum - Powering Communities
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Groups] Back to home page 
[Register] Register /  [Login] Login 


The final version of JForum 2.7.0 has been released with lots of improvements. Read all about it here

Running the JForum2 unit tests RSS feed
Forum Index » Developer Forum
Author Message
udittmer


Joined: 2013/2/21
Messages: 319
Online
This post is more of a note to myself than a question, but if anyone has suggestions on how to make the process smoother, I'm all ears.

1) Temporarily remove the net.jforum.summary.SummaryTest.java file. The test never finishes, although that may be more of a Quartz issue than an issue with the test itself.

2) Add the jforum-custom.conf file from your installation to src/main/config - it contains the DB configurations needed to run the tests.

3) Temporarily remove src/main/config/database/postgresql/postgresql.properties (or the corresponding file for whatever DB you're using for the tests). The file is loaded after the jforum-custom.properties, and thus overrides it.

An alternative to steps 2 and 3 would be to edit src/main/config/database/postgresql/postgresql.properties so it contains the values appropriate to your DB.

4) Then perform a clean build when running the tests.

5) Afterwards, undo the above changes before creating the actual build.

Ping & Net - my free Android app for TCP/IP network diagnostics
[Email] [WWW]
 
Forum Index » Developer Forum
Go to:   
Mobile view
Powered by JForum 2.7.0 © 2020 JForum Team • Maintained by Andowson Chang and Ulf Dittmer